Kevin Vance - Grr. DOSEMU does not compile with my 2.4 kernel includes. When I…

Entries | Archive | Friends | Friends' Friends | User Info

12:02 pm

Monday, June 12th, 2000
Previous Entry Share Next Entry
Tags,

Grr. DOSEMU does not compile with my 2.4 kernel includes. When I replace them with the 2.2 includes, it compiles and the executable segfaults. When I put the 2.4 includes back and remove the #include <string.h> from fs.h, it compiles a segfaulting executable. Double grr.

An strace reveals -- hehe, Freakazoid is on Cartoon Network -- that it segfaults right after a bind -- heh, I can't be angry with DOSEMU while funny cartoons are on. Freakazoid, dah na nah...

Link )Reply )

Comments
[User Picture]From: czircon
2000-06-12 09:31 am (UTC)
Dah na nah?

I have fond memories of Freakazoid... from like three weeks ago. Hee hee.
(Reply) (Thread)
[User Picture]From: kvance
2000-06-12 10:05 am (UTC)

Re:

Dah na nah because I forgot the words.

And it must have been a good couple of years since I've seen Freakazoid on, along with Animaniacs and shows of that ilk.

(Reply) (Parent) (Thread)
[User Picture]From: teferi
2000-06-12 03:19 pm (UTC)

The Debian package version works.

I'm using the same precompiled binary of DOSemu that comes in the debian package, haven't had any problems except that xdos doesn't work, but it's always had that problem.
(Reply) (Thread)
[User Picture]From: kvance
2000-06-12 04:50 pm (UTC)

Re: The Debian package version works.

No xdos? Icy. Of course, since the matrox code mysteriously stopped working in 1.0, xdos all I've got.
(Reply) (Parent) (Thread)
[User Picture]From: kvance
2000-06-12 04:54 pm (UTC)

Re: The Debian package version works.

There's supposed to be an "is" in there somewhere.
(Reply) (Parent) (Thread)