Kevin Vance - My VFD mounting bracket and internal cable arrived today! The…

Entries | Archive | Friends | Friends' Friends | User Info

07:48 pm

Monday, March 3rd, 2008
Previous Entry Share Next Entry
Front panel with VFD

My VFD mounting bracket and internal cable arrived today! The snap-in drive rails didn't work, so I used screws. But other than that, this is the first part of this project that has worked properly! It looks so pretty under the darkened plexiglass window.
Link )Reply )

Comments
From: c99koder
2008-03-04 01:31 am (UTC)
Looks nice! Interesting that the solid blocks on your display are actually solid -- for some reason LCDd loads an odd font into my 20x2 LCD that adds a little design to them. You can see what I mean here: http://www.flickr.com/photos/samsteele/476728152/in/set-72157600155847279/
(Reply) (Thread)
[User Picture]From: kvance
2008-03-04 01:44 am (UTC)
Huh, they look like little question marks. Have you tried the cvs version of lcdproc? There seem to be a lot of important bugfixes that aren't in the stable version yet.
(Reply) (Parent) (Thread)
From: c99koder
2008-03-04 02:12 am (UTC)
Yeah, they look like inverse capital letter P's. All the other customer characters work fine (the heart, the not-quite-filled blocks) just the 100% full block is wrong. I'll try building the cvs version, I'm just using whatever comes with ubuntu right now. It might be nice to have the progress bars actually look like progress bars :)
(Reply) (Parent) (Thread)
From: c99koder
2008-03-04 03:05 am (UTC)
I fixed it! I uncommented the filled_block bitmap and loaded it into a custom character slot instead of using the built-in 0xFF filled block character. Not sure why 0xFF was being replaced by an inversed capital P but it works now. It's so weird seeing actual bars after seeing the wrong character for months and months :P
(Reply) (Parent) (Thread)
[User Picture]From: kvance
2008-03-04 03:55 am (UTC)
Heh! That is strange...
(Reply) (Parent) (Thread)